Les ver­sions 4.0.2, 3.6.6 et 3.4.12 sont dis­po­ni­bles en fran­çais.

Les versions 3.4.12 et 3.6 corrigent seulement des bogues de securité. La version 4.0.2 corrige ces mêmes bogues de sécurité ainsi que d’autres bogues utiles :

  • La méthode de webservice Bug.create envoie maintenant une erreur si vous passez un nom de groupe qui n’existe pas. Dans Bugzilla 4.0 et 4.0.1, le nom de groupe était ignoré silencieusement, laissant votre bogue non sécurisé si aucun autre groupe n’était appliqué. (Bogue 653341)
  • Le déplacement de plusieurs bogues à la fois dans un autre produit affichait la même page de confirmation encore et encore, et les changements n’étaient jamais enregistrés (régression de la version 4.0). (Bogue 663208)
  • Marquer un bogue comme doublon fonctionne maintenant sous Internet Explorer 9. (Bogue 656769)
  • importxml.pl ne plante plus lors de l’importation de mots-clés (régression de la version 4.0). (Bogue 657707)
  • Les données saisies lors d’un rapport de bogue pouvaient être perdues en cliquant sur le bouton « Précédent » du navigateur Web. (Bogue 652427)
  • Les méthodes de webservices renverront désormais les champs de bogue indéfinis comme étant indéfinis au lieu de renvoyer une chaîne vide. Ce changement est cohérent avec le comportement de Bugzilla 4.2. (Bogue 657561)
  • L’interface XML-RPC fonctionne à présent avec SOAP::Lite 0.711 et 0.712 en mod_perl. (Bogue 600810)
  • LWP 6.00 et supérieur nécessitent Perl 5.8.8 ou supérieur. Lors de l’installation de ce module en utilisant install-module.pl sur une installation avec une version Perl inférieure à la version 5.8.8, LWP 5.837 sera installé à la place. (Bogue 655912)
  • La consultation d’un rapport de bogue devrait désormais être beaucoup plus rapide si votre installation contient beaucoup de champs personnalisés. (Bogue 634812)

L’équipe des développeurs de Bugzilla recommande vivement de faire la mise à jour vers la version 4.0.2 qui est bien plus stable et utilisable que les versions précédentes.

Il est à noter que dès la publication de Bugzilla 4.2 qui devrait intervenir en fin d’année, la série 3.4.x ne sera plus supportée.

Ce billet est une traduction libre du billet original en anglais.

Comme tou­jours, vous pou­vez télé­char­ger les ver­sions fran­ci­sées sur notre page Bug­zilla.